Michael Moore posted ...

50mm 1.4 not recording EXIF lens info?

Login to start new topic
Help topics

50mm 1.4 not recording EXIF lens info?

Category: General Discussion

Posted: 08-8-11 10:13 PM - Views: 3251

By: Michael Moore

Back to post list

0

Share this topic with your colleagues

Start of discussion

I wanted to check with other folks using the Planar 50mm f/1.4 lens, and find out whether this lens records anything more than "50mm" in the lens portion of the EXIF data. On my copy, that's all I get, which makes it a minor annoyance if I try to use Lightroom's lens correction feature. Other Zeiss lenses put the full lens name in EXIF.

TIA for any feedback.
Back

Replies ...

Reply Nr.8 from Russell Dyer on 02-22-12 12:19 AM

So, that's it? That's all that Zeiss has to say about the problem? "This situation is normal and does not indicate any problem with the lens?" Zeiss doesn't say, "Sorry for the inconvenience. We're working on a firmware solution?" I just bought one this month and it still has this problem. I can work around it by changing the exif data behind the scenes for my photos, but it seems silly to have to do this.

I wish Adobe Lightroom would allow me to set the exif data and would stop protecting it. It's easy to change with a simple program like exiftool: why bother blocking it in LR? But that's another topic.
Reply Nr.7 from Zeiss Images on 11-27-11 3:53 PM

I grabbed one of your pictures and this is all the info jhead shows


Exif header 4587 bytes long
Exif section in Intel order
(dir has 4 entries)
XResolution = 96/1
YResolution = 96/1
ResolutionUnit = 2
Copyright = "© Copyright 2011 Michael B. Moore"
Continued directory (dir has 6 entries)
Compression = 6
XResolution = 72/1
YResolution = 72/1
ResolutionUnit = 2
ThumbnailOffset = 208
ThumbnailLength = 4371
Thumbnail size: 4371 bytes
Jpeg section marker 0xed size 4564
Jpeg section marker 0xe2 size 3160
Jpeg section marker 0xee size 14
Jpeg section marker 0xdb size 132
JPEG image is 2000w * 1333h, 3 color components, 8 bits per sample
Jpeg section marker 0xdd size 4
Jpeg section marker 0xc4 size 418
File name : gallery/1164/U1164I1310616120.SEQ.4.jpg
File size : 1190457 bytes
File date : 2011:07:13 23:02:01
Resolution : 2000 x 1333

And here is what one of my files shows

Exif header 22595 bytes long
Exif section in Intel order
(dir has 8 entries)
Make = "Canon"
Model = "Canon EOS 5D Mark II"
XResolution = 240/1
YResolution = 240/1
ResolutionUnit = 2
Software = "Adobe Photoshop Lightroom 3.4"
DateTime = "2011:11:26 13:19:53"
ExifOffset = 204
Exif Dir:(dir has 26 entries)
ExposureTime = 1/50
FNumber = 56/10
ExposureProgram = 3
ISOSpeedRatings = 200
ExifVersion = "0230"
DateTimeOriginal = "2011:11:26 11:07:49"
DateTimeDigitized = "2011:11:26 11:07:49"
ShutterSpeedValue = 5643856/1000000
ApertureValue = 4970854/1000000
ExposureBiasValue = 0/1
MaxApertureValue = 2/1
MeteringMode = 5
Flash = 16
FocalLength = 25/1
SubSecTimeOriginal = "87"
SubSecTimeDigitized = "87"
FocalPlaneXResolution = 5616000/1459
FocalPlaneYResolution = 3744000/958
FocalPlaneResolutionUnit = 2
CustomRendered = 0
ExposureMode = 0
WhiteBalance = 0
SceneCaptureType = 0
Unknown Tag a431 Value = "320108902"
Unknown Tag a432 Value = 25/1, 25/1, 0/0, 0/0
Unknown Tag a434 Value = "25mm"
Continued directory (dir has 6 entries)
Compression = 6
XResolution = 72/1
YResolution = 72/1
ResolutionUnit = 2
ThumbnailOffset = 776
ThumbnailLength = 21811
Thumbnail size: 21811 bytes
Jpeg section marker 0xe2 size 576
Jpeg section marker 0xed size 22000
Jpeg section marker 0xdb size 67
Jpeg section marker 0xdb size 67
JPEG image is 450w * 675h, 3 color components, 8 bits per sample
Jpeg section marker 0xc4 size 31
Jpeg section marker 0xc4 size 73
Jpeg section marker 0xc4 size 30
Jpeg section marker 0xc4 size 92
File name : gallery/4/med_U4I1322343481.SEQ.6.jpg
File size : 581607 bytes
File date : 2011:11:26 15:38:01
Camera make : Canon
Camera model : Canon EOS 5D Mark II
Date/Time : 2011:11:26 11:07:49
Resolution : 450 x 675
Flash used : No
Focal length : 25.0mm (35mm equivalent: -2147483648mm)
Exposure time: 0.020 s (1/50)
Aperture : f/5.6
ISO equiv. : 200
Whitebalance : Auto
Metering Mode: matrix
Exposure : aperture priority (semi-auto)


Reply Nr.6 from Sikko Hoekstra on 11-27-11 3:29 PM

Hello,

I'm also use a planar 50mm f1.4 ZE and my lens does records exif info.
Camera used is a EOS 7D.

Here an example of EXIF info shown in Breeze Browser:

File: _MG_7731.CR2
File size: 22,4MB
Image Serial Number: 000-7731
Camera Model: Canon EOS 7D
Camera serial number: 0380319934
Firmware: Firmware Version 1.2.5
Date/Time: 2011:11:27 16:09:39
Copyright: Sikko Hoekstra
Shutter speed: 1/60 sec
Aperture: 3,5
Exposure mode: Program
Flash: External E-TTL
Metering mode: Evaluative
Drive mode: Continuous
ISO: 100
Lens: 50mm
Focal length: 50mm
Subject distance: 256 m
AF mode: Manual Focus
Image size: 3456 x 5184
Image quality: Raw
White balance: Auto
Picture style: Standard
Color space: AdobeRGB
Saturation: Normal
Sharpness: 3
Contrast: Normal
Tone: Normal
Custom Functions:
CFn I-7: 1/250 sec flash sync (fixed) in Av mode
CFn II-1: Long exposure noise reduction: AUTO
CFn III-1: AI Servo tracking sensitivity: Normal+
CFn III-6: AF Selection mode:
Auto selection: 19 point AF
Manual selection: Zone AF
Manual selection: AF point expansion
Manual selection: Single point AF
Manual selection: Spot AF
CFn III-8: VF display illumination: Enable
CFn IV-1: Multi-function button: VF electronic level

And when i export a picture from
RAW to JPG it shows the next info in the EXIF file.

ile: _MG_7731.jpg
File size: 995KB
Image Serial Number: 000-7731
Camera Model: Canon EOS 7D
Camera serial number: 380319934
Firmware: 1.2.5
Owner: Sikko Hoekstra
Date/Time: 2011:11:27 16:09:39
Copyright: Sikko Hoekstra
Shutter speed: 1/60 sec
Aperture: 3,5
Exposure mode: Program
Flash: On
Metering mode: Multi-segment
ISO: 100
Lens: 50mm
Focal length: 50mm
Image size: 3456 x 5184
Color profile: sRGB IEC61966-2.1
Reply Nr.5 from Petr on 10-18-11 12:17 AM

Hi , my lens 50mm/1,4 is too not recording EXIF info , but Distagon 21/2,8 yes...
Reply Nr.4 from Michael Moore on 09-18-11 5:24 PM

It's the ZE version on a Canon 5DII. Also happens on a 7D.

The 35mm 1.4 does the same thing - only records "35mm" under lens info. Kind of a bummer because LR picks the wrong lens for both. (50mm Makro and 35 2.0)
Reply Nr.3 from Michael Moore on 09-15-11 5:53 AM

I got an official reply on this back from Zeiss, so I thought I'd post it here in case others were wondering.

Dear Mr. Moore,

Yes, this situation is normal and does not indicate any problem with the lens.

Sincerely,
Richard Schleuning
Reply Nr.2 from Michael Moore on 08-16-11 7:11 AM

Thanks JT I'm using the ZE version. It's not a huge deal, but if I use the lens correction feature in Lightroom, it automatically picks the Makro 50 since it's the first one on the list.

Also, I just found out the 35 1.4 does the same thing. :(
Reply Nr.1 from Zeiss Images on 08-9-11 8:58 AM

Which version? ZF or ZE in either case, the ZF.2 will record data. the ZF.1 will need to have the camera programmed for a non cpu lens. The ZE will record regardless.
Please login to post or reply

Advertise your company and services on ZeissImages.
Send us an email to support@zeissimages.com

ZeissImages is 100% free to you.
Even a one time donation or subscription can really go a long way in helping to run the site.

Thanks for your support !