zeissimages.com
Viewing mode:   Light  -  Dark

Forum Home |

135mm f/2 Apo Sonnar T* ZF.2 - aperture control with the camera

avatar
Norway walter | 2017-09-04 | Viewed 97 times | Bottom
I bought a used Zeiss 135mm f/2 Apo Sonnar T* ZF.2 for my Nikon D750 and cannot figure out HOW to activate the aperture control from within the camera by using the Sub-Control Dial (on the front) to change the aperture.

In the Zeiss Instruction Manual it says:
"This ensures metering compatibility with all current Nikon DSLRs. When locked at the smallest aperture (marked in orange colour), the aperture can be set on the camera with any current Nikon DSLR (just as with any AF lens that features an aperture ring). There's an unlock button on the lens to release the aperture ring and set the aperture on the lens instead"

When my lens is set to its larges aperture-value (f/22) and locked there - as described in the manual - nothing happens, and the aperture remains on f/22, but when I MANUALLY turn the aperture-ring on the lens the aperture changes accordingly, and the metering (in Aperture Priority Mode) is correct. The right aperture-value is shown in the contral-panel (camera-top) and in the viewfinder. Also all the right data is written into the EXIF.

I have entered the right values into the camera's menu systen under "Non-CPU Lens data" as it should and all that is working O.K.

Anyone has any ideas of what is wrong? How to go about?

I have to add that I also have a Carl Zeiss Planar 50mm f/1.4 ZF.2 which works just fine on my D750 with full aperture control by the Sub-Control Dial on the camera when the aperture-ring is locked at the smallest aperture f/22 (marked in orange colour) as described in the user maual.

By the way, I also have the latest FirmWar Update on my D750.

Best regards,
Walter from Norway!

Reply # 3

avatar
Norway walter | 09-19-17 5:03 AM | Bottom
Came to the conclusion that the CPU on the lens must be defect / not working as it should. Must send the lens to Germany (Göttingen?) to replace parts.

Reply # 2

avatar
Norway walter | 09-6-17 1:55 AM | Bottom
Hello Jorge Torralba!

Thank you for answering my plea her.

Well, I have read the manual carefully, and done all that. The Aperture-ring is set to f/22 and the lock-button is in place (cannot jiggle the ring anymore). The indexing-lever is "fixed" on the D750 and cannot be foldet in (thats on the the dF), so both these settings should be O.K.

Also, I use the 50mm Zeiss Planar f/1.4 ZF.2 the same way on the same cameras - and this one works as it should, while the 135mm Apo Sonnar does not. That is what throughs me off, you see.

One Zeiss works O.K. and the other (which should work the same way) does not!

Walter

Reply # 1

avatar
United States torralba | 09-5-17 7:27 PM | Bottom
you need to set it to f22 and make sure it will not move from that position unless you push the little button on the aperture ring. Then you can control aperture with the camera buttons.

Also make sure the indexing lever is facing outwards on your camera lens mount flange.

Top of Page

Even a one time donation or subscription can go a long way in helping run the site. Use the donate button of your choice.

Thanks for your support !

Gallery Software by Jorge Torralba

Home - Contact Us - Terms - Gallery by Lens - FAQ - Members - MTF - About - BI - Top - Forums - Contest Rules - Market